Why do I need libstdc++-5.0 ?


The reason is that Firebird binary you are installing was compiled on such machine - for the purpose of being compatible with older systems. Your system probably has libstdc++-6.0 or higher version installed.

Fixing this problem is easy, just find the package with libstdc++-5.0 and install it. If you use a RPM based distribution (RedHat, Fedora, CentOS, Mandriva, SuSE) go to rpmbone.net (or rpmfind.net) and search for .rpm package (named compat-libstdc++-33-3.2.3-61.i386.rpm or something similar). On Fedora you can also use Yum installer which does downloading and installing for you, all you need to do is to simply type:

yum -y install compat-libstdc++-33

If you use Slackware, install some gcc-g++-3.3.something.tgz package and then install the current g++ back (to make it the default once again). If you use .deb based distro like Debian, Ubuntu, Mepis, etc. use apt-cache search to find the needed package or install Firebird using apt-get instead of package from Firebird website.


Do you find this FAQ incorrect or incomplete? Please e-mail us what needs to be changed. To ensure quality, each change is checked by our editors (and often tested on live Firebird databases), before it enters the main FAQ database. If you desire so, the changes will be credited to your name. To learn more, visit our add content page.

If you are a commercial tool maker and your tool features a great way to handle the issue written about in this FAQ, please check out our advertisement page.



All contents are copyright © 2007-2017 FirebirdFAQ.org unless otherwise stated in the text.


Links   Firebird   News   FlameRobin   Home Inventory powered by FB  
Add content   Advertise   About  

Categories
 Newbies
 SQL
 Installation and setup
 Backup and restore
 Performance
 Security
 Connectivity and API
 HOWTOs
 Errors and error codes
 Miscellaneous