Why do I need libstdc++-5.0 ?
The reason is that Firebird binary you are installing was compiled on such machine - for the purpose of being compatible with older systems. Your system probably has libstdc++-6.0 or higher version installed.
Fixing this problem is easy, just find the package with libstdc++-5.0 and install it. If you use a RPM based distribution (RedHat, Fedora, CentOS, Mandriva, SuSE) go to rpmbone.net (or rpmfind.net) and search for .rpm package (named compat-libstdc++-33-3.2.3-61.i386.rpm or something similar). On Fedora you can also use Yum installer which does downloading and installing for you, all you need to do is to simply type:
yum -y install compat-libstdc++-33
If you use Slackware, install some gcc-g++-3.3.something.tgz package and then install the current g++ back (to make it the default once again). If you use .deb based distro like Debian, Ubuntu, Mepis, etc. use apt-cache search to find the needed package or install Firebird using apt-get instead of package from Firebird website.